gerrit-build: jammy updates: update to nodejs 18.x, allow submodule clones

It seems there's no jammy repositories for nodejs 10.x.  Upstream
reccommends "at least" LTS v16 -- the current LTS is 18 so let's try
that.

Also update the git config to allow the submodule clones per the
recent CVE's.

[1] https://gerrit.googlesource.com/gerrit/+/master/polygerrit-ui/README.md#installing-node_js-and-npm-packages

Change-Id: I1492e4c136c18155eb3cb7fed24b413b250c78b5
changes/34/864234/6
Ian Wienand 3 months ago
parent 2cd574c16f
commit c78e410373
No known key found for this signature in database

@ -3,7 +3,7 @@
- role: ensure-java
java_version: 11
- role: ensure-nodejs
node_version: 10
node_version: 18
- ensure-bazelisk
tasks:
- name: Install essential build packages

@ -1,8 +1,8 @@
- hosts: all
tasks:
# https://github.blog/2022-10-18-git-security-vulnerabilities-announced/
- name: Checkout submodules
shell: "if [ -d {{ item }} ] ; then git submodule update --init {{ item }} ; fi"
shell: "if [ -d {{ item }} ] ; then git -c protocol.file.allow=always submodule update --init {{ item }} ; fi"
args:
chdir: /home/zuul/src/gerrit.googlesource.com/gerrit
loop:

Loading…
Cancel
Save