Use nodejs 14

According to upstream gitea nodejs 16 has broken them and there isn't
much they can do other than using nodejs 14 for the moment. Use 14 in
our image builds to keep our dockerfile buildable.

See https://github.com/go-gitea/gitea/issues/16604 for more info.

Change-Id: I143c3e67f354d220614136905e8b598cd6d2ad61
changes/65/803265/1
Clark Boylan 2 years ago
parent 47d1737cd7
commit 28736e31ba

@ -32,7 +32,7 @@ ENV TAGS "bindata $TAGS"
#Build deps
RUN apt-get update && apt-get -y install build-essential git apt-transport-https curl gnupg2 \
&& curl -sS https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add - \
&& echo "deb https://deb.nodesource.com/node_16.x buster main" | tee /etc/apt/sources.list.d/nodesource.list \
&& echo "deb https://deb.nodesource.com/node_14.x buster main" | tee /etc/apt/sources.list.d/nodesource.list \
&& apt-get update \
&& apt-get -q --option "Dpkg::Options::=--force-confold" --assume-yes install nodejs \
&& mkdir -p ${GOPATH}/src/code.gitea.io/gitea

Loading…
Cancel
Save